Bug: Zombies replacing mob on server restart

Discussion in 'Bug Reports' started by LOVLOK, May 22, 2020.

  1. LOVLOK

    LOVLOK New Member

    Joined:
    May 17, 2020
    Messages:
    4
    Likes Received:
    0
    Enter a brief description of what is broken Zombies replacing mob on server restart

    What version of Minecraft are you using?
    1.15

    What server jar are you using? Spigot

    What is this a bug report for? MythicMobs

    What version of the plugin are you using? MythicMobs-4.9.1

    Describe the bug. Be as specific as possible, images or short gifs/videos are welcome but save configuration files for later sections. Write a whole paragraph if needed, help us bug testers replicate your issue!
    Zombies replacing mob on server restart

    Before restarting:
    https://i.gyazo.com/f023cd38dedda9f5873ece6532e02043.png

    After restart:
    https://gyazo.com/a2f07e289ca9e44c8691cbc9182f4583


    After restarting the previous mobs turn into Zombies. These zombies still have the name plate above their head, but they're just normal zombies that burn in the sunlight even though I coded my mobs to PreventSunBurn: true.

    Example Configurations
    Floor1Rascal:
    Type: ZOMBIE
    Display: "&7[Level <mob.level>] &7Rascal"
    Health: 50
    Damage: 2
    Faction: Wild
    Options:
    MovementSpeed: 0.3
    PreventSunburn: true
    PreventOtherDrops: true
    PreventRandomEquipment: true
    MaxCombatDistance: 50
    FollowRange: 12
    KnockbackResistance: 0.5
    Despawn: true
    Silent: true
    Skills:
    - randomskill{skills=Level3,Level4,Level5,Level6,Level7,Level8} ~onSpawn
    - damage{amount=2;ignoreArmor=false} @EntitiesInCone{angle=10;range=2;} ~onTimer:20
    LevelModifiers:
    Health: 10
    Damage: 1
    Drops:
    - Money 10 0.8
    Disguise:
    Type: player
    Skin: nb03
    Burning: false
    Blocking: false
    Invisible: false
    ShowName: true
    Sneaking: false
    Sprinting: false
    ModifyBoundingBox: false
    AIGoalSelectors:
    - 0 clear
    - 1 meleeattack
    - 2 randomstroll
    AITargetSelectors:
    - 0 clear
    - 1 players
    - 2 attacker
     
    #1
  2. LOVLOK

    LOVLOK New Member

    Joined:
    May 17, 2020
    Messages:
    4
    Likes Received:
    0
    Any ideas? or is this a fault in my own?
     
    #2
  3. EASYgamesSK

    EASYgamesSK Member

    Joined:
    Jun 1, 2019
    Messages:
    36
    Likes Received:
    6
    Hey,
    I think MythicMobs should despawn after closing or restarting server so there must be definitely something wrong on your side. But, were these mobs spawned by MythicSpawner or by commands?
     
    #3
  4. Seyarada

    Seyarada Member
    Quality Assurance

    Joined:
    Jun 16, 2019
    Messages:
    165
    Likes Received:
    21
    This is a MythicMobs issue where the plugin forgets - somehow - that those entities were mythicmobs, I don't thiink there's any solution for it other than not restarting the server
     
    #4

Share This Page