Bug: vanilla targeters require radius-argument

Discussion in 'Bug Reports' started by jaylawl, Mar 6, 2016.

  1. jaylawl

    jaylawl Community Manager
    Super Moderator Supporter Premium Supporter Quality Assurance

    Joined:
    Sep 16, 2015
    Messages:
    1,763
    Likes Received:
    171
    Please fill out the following information to ensure your bug report is resolved as quickly as possible. Incomplete or non-detailed reports, or errors caused by bad syntax, may be closed without explanation. Also, please surround any configurations in your post with code tags.

    MC Server Type & Version: spigot 1.9
    MythicMobs Version / Build: 2.3.2 #1441

    Do you see any additional errors on MythicMobs load/reload? no

    Please describe in detail the problem you are encountering and the steps to replicate it

    Vanilla targeters (with any combination of arguments ive tried so far) are reluctant to work if the "radius" argument isnt provided. Simply using @a or @p won't work. Neither will @a[c=1] or @p[c=3] for example. It must have @a[r=100] or @p[r=30] . Some radius must be given.
     
    #1
  2. xikage

    xikage Administrator
    Administrator Developer Supporter

    Joined:
    Jul 18, 2015
    Messages:
    645
    Likes Received:
    226
    I don't know why this is, but the way it works now is that MM passes those directly to the same parser command blocks use. I don't know if they inject a default radius or something somewhere along the line, but other than that there's not much we can do about this one.
     
    #2

Share This Page