Bug: Banner Placement is broken after giving a display name

Discussion in 'Bug Reports' started by MooshroomStatus, Dec 6, 2018.

  1. MooshroomStatus

    MooshroomStatus Active Member

    Joined:
    May 25, 2016
    Messages:
    106
    Likes Received:
    31
    Enter a brief description of what is broken Banner Placement is broken after giving a display name

    What version of Minecraft are you using?
    1.12

    What server jar are you using? Spigot

    What is this a bug report for? MythicMobs

    What version of the plugin are you using? 4.4.1

    Describe the bug. Be as specific as possible, images or short gifs/videos are welcome but save configuration files for later sections. Write a whole paragraph if needed, help us bug testers replicate your issue!
    When creating a banner, if you so choose to give it a display name, you will lose the ability to place it anywhere. This seems to only be the case with a display name, as I've added lore to my banner and it was placeable still, but as soon as I named it something, It became unplaceable.

    Example Configurations
    (Test 1 (WORKING))
    TavernBanner:
    Display: ''
    Id: 425
    Lore:
    - 'Show your support for the Tavern!'
    Options:
    Color: GRAY
    BannerLayers:
    - GREEN FLOWER
    - SILVER BRICKS
    - LIGHT_BLUE BORDER
    - BLACK TRIANGLE_BOTTOM
    - GREEN STRIPE_BOTTOM
    - LIGHT_BLUE TRIANGLES_TOP

    (Test 2 (BROKEN))
    TavernBanner:
    Display: 'Tavern Banner'
    Id: 425
    Lore:
    - 'Show your support for the Tavern!'
    Options:
    Color: GRAY
    BannerLayers:
    - GREEN FLOWER
    - SILVER BRICKS
    - LIGHT_BLUE BORDER
    - BLACK TRIANGLE_BOTTOM
    - GREEN STRIPE_BOTTOM
    - LIGHT_BLUE TRIANGLES_TOP
     
    #1

Share This Page