Vanilla Issue Bug: Attributes Applying Wrongly

Discussion in 'Bug Reports' started by Scarista, Jan 7, 2019.

  1. Scarista

    Scarista New Member
    Supporter Premium Supporter

    Joined:
    Jan 7, 2019
    Messages:
    1
    Likes Received:
    0
    Enter a brief description of what is broken Attributes Applying Wrongly

    What version of Minecraft are you using?
    1.12

    What server jar are you using? Spigot

    What is this a bug report for? MythicMobs

    What version of the plugin are you using? v4.5.0

    Describe the bug. Be as specific as possible, images or short gifs/videos are welcome but save configuration files for later sections. Write a whole paragraph if needed, help us bug testers replicate your issue!
    Any custom Item I create, when adding attributes, breaks the weapons attack speed. The item I've linked for instance, has "HEALTH: 2" but the weapons speed is about the same as a fist. Once the "HEALTH: 2" is removed, it returns to normal speed.
    I've tested making a weapon with only the Attributes, and no other changes, such as the following:

    FillerTest:
    Id: DIAMOND_SWORD
    Display: 'test item'
    Attributes:
    Mainhand:
    Health: 2
    ~~~~
    This has the exact same issue. The issue is fixed when "HEALTH: 2" is removed. On a side note, the Health effect does work, even though the weapon speed is broken.

    ~
    Spigot 1.12.2-R0.1 most recent version.

    Example Configurations
    ITEM::
    https://gist.github.com/Scabista/fc48c5d5c8cb45f67d950c8c15d9a450
    ~~
    CONFIG::
    https://gist.github.com/Scabista/2f9141ba42c17b5dee37f9f276da252c
     
    #1
  2. Daxxas

    Daxxas Member
    Supporter Premium Supporter Quality Assurance Moderator

    Joined:
    Aug 7, 2016
    Messages:
    42
    Likes Received:
    4
    Bug confirm in Mythicmobs 4.6.0
     
    #2
  3. xikage

    xikage Administrator
    Administrator Developer Supporter

    Joined:
    Jul 18, 2015
    Messages:
    637
    Likes Received:
    222
    This is a vanilla Minecraft bug. Adding any NBT to an item will wipe the default values, so you need to define AttackSpeed yourself.
     
    #3

Share This Page