Resolved 4.0.0 (1951) - Spawners at a distance not spawning, despite showing as spawned

Discussion in 'Resolved Issues' started by Mixxit, Feb 17, 2017.

  1. Mixxit

    Mixxit Member
    Supporter Premium Supporter

    Joined:
    Jun 10, 2016
    Messages:
    42
    Likes Received:
    2
    What MythicMobs version or build # are you using?
    4.0.0 (1951)

    What server jar are you using?

    Spigot 1.11.2

    What MythicLib jar are you using?
    /version mythiclib reports 0.0.1-SNAPSHOT but im not sure if you guys are updating the version field in plugin.yml
    *Edit* This appears to be 1.0.1

    Describe the bug. Be as specific as possible, images or short gifs/videos are welcome but save configuration files for later sections. Write a whole paragraph if needed, help us bug testers replicate your issue!
    When logging in, mobs around me will spawn, but when travelling to a distant location where a spawner should be spawned, the mob never spawns, despite waiting 20 minutes

    I can see the flames pulsing on the ground, the timers in 'spawners info' are at 0 and the spawner shows as spawned, but the npc isnt visible - see image below

    Note: if I restart the server and spawn in this location from the start, this mob will spawn fine, also if i do /mm reload the mob will also spawn fine

    I believe this is something to do with distance to player perhaps on the initialisation of the spawner?

    Image of Spawner Issue
    [​IMG]

    Configurations:
    Note, this happens with all npcs and spawners, but I will list them for brevity

    NPC Configuration:
    NPCID_44:
    Type: SKELETON
    Display: Shield_Thuldir
    Health: 637
    Damage: 32
    Faction: FACTIONID_4
    MovementSpeed: 0
    MaxCombatDistance: 15
    PreventOtherDrops: true
    PreventRandomEquipment: true
    Options:
    PreventMobKillDrops: true
    PreventOtherDrops: true
    Silent: true
    ShowHealth: true
    PreventRenaming: true
    PreventRandomEquipment: true
    AlwaysShowName: true
    Modules:
    ThreatTable: true
    AIGoalSelectors:
    - 0 clear
    - 1 skeletonbowattack
    - 2 meleeattack
    AITargetSelectors:
    - 0 clear
    - 1 attacker
    - 2 SpecificFaction FACTIONID_2
    - 3 SpecificFaction FACTIONID_14
    - 4 SpecificFaction FACTIONID_15
    Equipment:
    - CUSTOMHEADNPCID_44:4
    - IRON_CHESTPLATE:3
    - IRON_LEGGINGS:2
    - IRON_BOOTS:1
    - IRON_SWORD:0
    Skills:
    - command{c="execute <mob.uuid> ~ ~ ~ entitydata <mob.uuid> {Rotation:[84.15259f,0f]}"} @self ~onSpawn

    SpawnGroup Configuration:

    SPAWNGROUPID_9:
    MobName: NPCID_44
    World: world
    X: 905
    Y: 64
    Z: -1016
    Radius: 0
    UseTimer: true
    MaxMobs: 1
    MobLevel: 1
    MobsPerSpawn: 1
    Cooldown: 0
    CooldownTimer: 0
    Warmup: 360
    WarmupTimer: 0
    CheckForPlayers: false
    ActivationRange: 256
    LeashRange: 128
    HealOnLeash: false
    ResetThreatOnLeash: false
    ShowFlames: false
    Breakable: false
    Conditions: []
    ActiveMobs: 1
     
    #1
    Last edited: Feb 17, 2017
  2. Mixxit

    Mixxit Member
    Supporter Premium Supporter

    Joined:
    Jun 10, 2016
    Messages:
    42
    Likes Received:
    2
    Here is some debug output on another random spawner that is failing to display the NPC in game


    spawners info also lists the entity as d718606f-f8cc-4ce0-b924-e865d3c7de50

    Searching my logs i find the following lines:

    [17:01:46] [Craft Scheduler Thread - 51/INFO]: [MythicMobs] * Queued CleanUp for mob d718606f-f8cc-4ce0-b924-e865d3c7de50
     
    #2
  3. Mixxit

    Mixxit Member
    Supporter Premium Supporter

    Joined:
    Jun 10, 2016
    Messages:
    42
    Likes Received:
    2
    Enabling Despawn: false this issue does not occur so
     
    #3
  4. Mixxit

    Mixxit Member
    Supporter Premium Supporter

    Joined:
    Jun 10, 2016
    Messages:
    42
    Likes Received:
    2
    Now Despawn: false is causing double/triple spawning

    /mm reload does not remove them

    eek
     
    #4
    Last edited: Feb 17, 2017
  5. Mixxit

    Mixxit Member
    Supporter Premium Supporter

    Joined:
    Jun 10, 2016
    Messages:
    42
    Likes Received:
    2
    Tested if this was due to disguises but it is happening without them also

    Something is terribly wrong with the spawners
     
    #5
    Last edited: Feb 17, 2017
  6. Xikage

    Xikage Administrator
    Administrator Developer Super Moderator Supporter Premium Supporter Quality Assurance

    Joined:
    Jul 18, 2015
    Messages:
    657
    Likes Received:
    230
    Can someone confirm if this has been fixed in the latest dev builds?
     
    #6
    Mixxit likes this.
  7. Mixxit

    Mixxit Member
    Supporter Premium Supporter

    Joined:
    Jun 10, 2016
    Messages:
    42
    Likes Received:
    2
    You're doing gods work! from what I can see after zooming around the map all mobs appear to be spawned! :)
     
    #7

Share This Page