[Solved] Having trouble getting a skill command to run

Discussion in 'Support' started by LadyHaley, Jan 12, 2018 at 6:34 AM.

  1. LadyHaley

    LadyHaley New Member

    Joined:
    Dec 7, 2017
    Messages:
    7
    Likes Received:
    2
    I'm trying to use the command mechanic that would allow mobs to use spells from the magic plugin I have installed on my server.

    The command '/cast basicspell -40,77,225 @t LadyHaley' works perfectly fine in game but I cant get it to run as a skill through mythic mobs.

    dMage:
    Type: ZOMBIE
    Health: 46
    Disguise:
    Type: player
    Skin: MageDude
    Player: '&8Dark Mage'
    Equipment:
    - stone_button:4
    - bone:0
    Skills:
    - skill{s=BasicSpell} @target ~onTimer:45
    - effect:particles{particle=reddust;c=#a30000;vs=2;hs=1;a=12} @self ~onTimer:60

    I have tried changing the targeter from @self to @target but thats not done much.

    Here is the config for the skill

    BasicSpell:
    Skills:
    - command{c=magespellsremastered:cast basicspell <mob.l.x>,<mob.l.y>,<mob.l.z> @t <target.name>}

    I have tried using ~,~,~ for the coods but thats not working, I have tried running this command 'minecraft:execute <mob.uuid> ~ ~ ~ magespellsremastered:cast basicspell <mob.l.x>,<mob.l.y>,<mob.l.z> @t <target.name>' but that has also not worked so im not really sure why its not working.

    Thanks in advanced
     
    #1
    Last edited: Jan 12, 2018 at 7:15 AM
  2. LadyHaley

    LadyHaley New Member

    Joined:
    Dec 7, 2017
    Messages:
    7
    Likes Received:
    2
    Issue Resolved
     
    #2

Share This Page