Recent bug with ~onUse

Discussion in 'Bug Reports' started by dwatsX, Aug 12, 2017.

  1. dwatsX

    dwatsX New Member
    Supporter

    Joined:
    Jun 5, 2016
    Messages:
    13
    Likes Received:
    2
    I saw someone post about this bug in another thread and I thought it might get more attention if I posted here.

    I'm using MM 4.2.0 and MythicArtifacts 0.1.10.

    Looks like items using the ~onUse trigger will only fire when the item BESIDE the MythicArtifact on the hotbar is selected with the mouse wheel. So a "wand" which previously worked fine, and fired a projectile when right clicked, now appears to do nothing - until you select the item on the hotbar beside this Wand. Then you can shoot it. This is a fairly recent bug which seems to have appeared in MythicArtifacts version 0.1.7 or so.

    Interestingly, when the plugin is reloaded, this same Wand which is supposed to fire a projectile when right clicked works properly, as long as it was the selected item on the hotbar when the plugin was reloaded. The item will continue to work properly until you select a different hotbar item - then you must use the item beside the Wand again to shoot it.

    I noticed this also produces a bunch of console spam where it says "Checking Item..." over and over. I've also tried replacing the ~onUse trigger with the ~onRightClick trigger, but ~onRightClick appears to do nothing at all.
     
    #1
    Narrator likes this.

Share This Page